Online Classes Available

contact for MCSA 2012,MCSE 2012,Exchange server 2010,VCP 5.5 (Free Demo)
call :+91-9654527967
Skype:neeraj_230@hotmail.com
Hangout:neerajdel@gmail.com

Thursday, May 1, 2014

Clear Cisco Router Configuration to Factory reset

Router#erase startup-config
Erasing the nvram filesystem will remove all files! Continue? [confirm]
[ OK]
Erase of nvram: complete
Router#reload
Proceed with reload? [confirm]

Auto Tuning Buffers on Cisco Router

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#buffers tune automatic
Router(config) #end
Router#

Router# show buffers tune
Tuning happened for the pool Small
Tuning happened at 22: 43: 19
Oldvalues
permanent: 50 minfree: 20 maxfree: 150
Newvalues
permanent: 62 minfree: 15 maxfree: 78
Tuning happened for the pool Middle
Tuning happened at 22: 43: 19
Oldvalues
permanent: 25 minfree: 10 maxfree: 150
Newvalues
permanent: 36 minfree: 9 maxfree: 45
Router#

Disabling Cisco Discovery Protocol (CDP) on Cisco Router

Disable per interface:

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config) #cdp run
Router(config) #interface FastEthernet0/0
Router(config-if) #no cdp enable
Router(config-if) #end
Router#

Disable globally:

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config) #no cdp run
Router(config) #end
Router#

Tuesday, April 8, 2014

Defining Encapsulations for VLAN between Router and Switch for Inter-VLANs Routing


Defining Encapsulations for VLAN between Router and Switch for Inter-VLANs Routing

Step1: Configue Port on Router for Logically divided an Fast Ethernet Port into 3 VLANs ports

Router(config)#interface FastEthernet0/0  (Enter the Fast Ethernet Port of Router)
Router(config-if)# no ip address        (Remove the IP address from the Interface)
Router(config-if)#no shutdown        (Give the Interface UP)
Router(config-if)#exit            (Exit from the Port)

Router(config)#interface FastEthernet0/0.2               (sub interface for the VLAN 2)
Router(config-subif)# encapsulation dot1Q 2         (IEEE 802.1Q Encapsulation for VLAN 2)   
Router(config-if)# ip address 10.1.1.1 255.0.0.0         (IP Address for the VLAN 2)
Router(config)#exit                (Exit from the Port)

Router(config)#interface FastEthernet0/0.3        (sub interface for the VLAN 3)
Router(config-subif)# encapsulation dot1Q 3    (IEEE 802.1Q Encapsulation for VLAN 3)
Router(config-subif)# ip address 20.1.1.1 255.0.0.0     (IP Address for the VLAN 3
Router(config-subif)#exit            (Exit from the Port)

Router(config-if)#interface FastEthernet0/0.4    (sub interface for the VLAN 4)
Router(config-subif)# encapsulation dot1Q 4    (IEEE 802.1Q Encapsulation for VLAN 4)
Router(config-subif)# ip address 30.1.1.1 255.0.0.0     (IP Address for the VLAN 4)
Router(config-subif)#exit            (Exit from the Port)


Step2: Now Create VLANs on The Switch

Switch(config)#vlan 2
Switch(config)#name Sale
Switch(config)#vlan 3
Switch(config)#name Hr
Switch(config)#vlan 4
Switch(config)#name IT

OUTPUT:
Switch#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24
2    sales                            active    Fa0/1
3    HR                               active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
                                                Fa0/6, Fa0/7, Fa0/8
4    IT                               active    Fa0/9, Fa0/10, Fa0/11, Fa0/12


Step3: Configure Port for Trunk
Switch(config)#interface F0/1
Switch(config-if)#switchport mode trunk

Step4: Now connect Different PC for Acess to VLANs.

PC1:     IP address: 10.1.1.2
    Subnet Mask: 255.0.0.0
    Default Gateway:10.1.1.1

PC2:    IP address: 20.1.1.2
    Subnet Mask: 255.0.0.0
    Default Gateway:20.1.1.1

PC3:    IP address: 30.1.1.2
    Subnet Mask: 255.0.0.0
    Default Gateway:30.1.1.1

Step5: Ping Each Other

On pc1 to pc2 and pc3

ping 10.1.1.2
ping 20.1.1.2
ping 30.1.1.2

 You see Each Reply for each ping.



IPv6 Address Types and Range

 Address Type            Bits (Binary)           HEX Representation
--------------------------------------------------------------------
Unspecified                     00...0                             ::/128

Loopback                         00...1                            ::1/128

Multicast                      11111111                           FF00::/8

Link-Local Unicast           1111111010              FE80::/10

Site Local Unicast           1111111011              FEC0::/10
(Depreciated)

Global Unicast               001                            2xxx::/ or 3xxx::/4
(Currently Allocated)

Reserved (Future Use)   Everything Else

 

IPv6 Multicast Address

Address            Multicast Group
------------------------------------
 FF02::1            All Nodes
 FF02::2            All Routers
 FF02::5            OSPFv3 Routers
 FF02::6            OSPFv3 DR's
 FF02::9            RIPng Routers
 FF02::A            EIGRP Routers
 FF02::B            Mobile Agents
 FF02::C            DHCP Servers
 FF02::D            All PIM Routers

Port Security Configuration on 2950 Switch

Switch(config-if)#switchport mode access

Switch(config-if)#switchport port

Switch(config-if)#switchport port-security ?
  mac-address  Secure mac address
  maximum      Max secure addresses
  violation    Security violation mode
  <cr>

Switch(config-if)#switchport port-security mac-address ?
  H.H.H   48 bit mac address
  sticky  Configure dynamic secure addresses as sticky

Switch(config-if)#switchport port-security mac-address 00e0.f75c.6301
Port-security not enabled on interface FastEthernet0/1.

Switch(config-if)#switchport port-security

Switch(config-if)#switchport port-security mac

Switch(config-if)#switchport port-security mac-address 00e0.f75c.6301

Switch(config-if)#^Z
Switch#
%SYS-5-CONFIG_I: Configured from console by console

Switch#sh mac address-table
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----

   1    00e0.f75c.6301    STATIC      Fa0/1
Switch#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Switch#
Switch#sh mac address-table
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----

   1    00e0.f75c.6301    STATIC      Fa0/1
Switch#sh mac address-table
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----

   1    00e0.f75c.6301    STATIC      Fa0/1
Switch#sh mac address-table
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----

   1    00e0.f75c.6301    STATIC      Fa0/1
Switch#sh mac address-table
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----

   1    00e0.f75c.6301    STATIC      Fa0/1
Switch#sh mac address-table
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----

   1    00e0.f75c.6301    STATIC      Fa0/1
Switch#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down


Switch#
Switch#
Switch#
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#int fastEthernet 0/1

Switch(config-if)#switchport port-security maximum 2

Switch(config-if)#shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
Switch(config-if)#
Switch(config-if)#
Switch(config-if)#no sh
Switch(config-if)#no shutdown

Switch(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Switch(config-if)#switchport port-security violation ?
  protect   Security violation protect mode
  restrict  Security violation restrict mode
  shutdown  Security violation shutdown mode

Switch(config-if)#switchport port-security violation shutdown
Switch(config-if)#^Z
Switch#
%SYS-5-CONFIG_I: Configured from console by console

Switch#sh mac AD
Switch#sh mac ADdress-table
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----

   1    00e0.f75c.6301    STATIC      Fa0/1
Switch#sh mac ADdress-table
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----

   1    00e0.f75c.6301    STATIC      Fa0/1
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config-if)#switchport port-security mac-address 0090.217C.CE02
Switch(config-if)#^Z
Switch#
%SYS-5-CONFIG_I: Configured from console by console

Switch#
Switch#
Switch#sh mac ADdress-table
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----

   1    0090.217c.ce02    STATIC      Fa0/1
   1    00e0.f75c.6301    STATIC      Fa0/1
Switch#

Friday, March 14, 2014

CCNA Basics Part-2

How to assign an IP address to the Router and configure it?

Router(config)# interface ethernet 0 /0  or  serial 0/0
Router(config-if)ip address <IP address> <Subnet Mask>
Router(config-if)no shutdown

 We assign our default-gateway as the IP address to the ethernet port.

 When the router is switched ON, by default all the interfaces are administratively down. To make the interfaces up we give no shutdown command.

Why and where we use the clock rate?

The serial line has two ends DTE and DCE. This line goes up and down when IP address and no shutdown is configured on both sides and will be in asynchronous state always. To synchronize the link clock rate should be configured at DCE end.


How to find out the DCE end?

Router#sh controllers serial 0/0


Difference between Request timed out Destination host unreachable

Syntex of the command to be used:

Reply from <ip address> : <byte= > time<xms TTL=xxx

Request timed out

When the packet is lost in transition, we will get “request timed out” message.
Destination host unreachable

If the host doesn’t know the route to the destination - “Destination unreachable” message is displayed i.e., the specified address is not present in the routing table

Reply from <ip address> : <byte= > time <xms TTL=xxx
Reply from the destination indicates that the connection exists

Time To Live (TTL) – a field in an IP header that indicates the no. of routers (hops) the packet can cross. TTL for systems is 128 and for routers it is 255. If the destination is not reached before the TTL expires, then the packet is dropped. This stops IP packets from continuously circling around in the network looking for a home

Saturday, March 8, 2014

CCNA Fundamentals (Basics)



Troubleshooting commands of Networking 

1. Ping loopback
2. Ping NIC
3. Ping default gateway
4. Ping remote device

Windows DOS Troubleshooting Commands

ping 127.0.0.1
tracert
ipconfig/all
arp -a

Cisco IOS Troubleshooting Commands

ping 127.0.0.1
traceroute

IP CLASSESS:

Class A - 1-126 - network.node.node.node
Class B - 128-191 - network.network.node.node
Class C - 192-223 - network.network.network.node

Private Address Range

Class A - 10.0.0.0 - 10.255.255.255
Class B - 172.16.0.0 - 172.31.255.255
Class C - 192.168.0.0 - 192.168.255.255

OSI Model 

Application - Identifying and establishing the availability of intended communication partner and
whether there are sufficient resources

Presentation - Data translation, encryption, code formatting

Session - Setting up, managing and tearing down sessions. Keeps application’s data separate

Transport - Provides end-to-end transport services - establishes logical connections
between hosts. Connection-oriented or connectionless data transfer.

Network - Manages logical addressing and path determination

Data Link - Provides physical transmission of data, handles error notification, flow
control and network topology. Split into two sub layers (LLC and MAC)

Physical - Specifies electrical, mechanical, procedural and functional requirements for activating, maintaining
and deactivating a physical link.

Cisco 3-Layer Hierarchical Model

Core - Backbone connectivity , common for all users, needs to be as fast as possible and fault tolerant, avoid ACL, VLAN trunking and packet filtering

Distribution - Routing - provides access control policies, filtering, WAN access and VLAN trunking

Access - Switching - User and workgroup access, segmentation

OSI Model vs. TCP/IP Model

Process/Application layer

FTP - TCP file transfer service – port 20-21
Telnet - Terminal emulation program – port 23
TFTP - UDP file transfer – port 69
SMTP - Send email service – port 25
DHCP – Assigns IP addresses to hosts –ports 67 and 68
DNS – Resolves FQDNs to IP addresses –port 53

Host-to-Host layer

TCP - Connection-oriented protocol, provides reliable connections
(acknowledgments, flow control, windowing)

UDP - Connectionless protocol, low overhead but unreliable
TCP/IP Model Protocol Suite Internet layer
IP - connectionless protocol, provides network addressing and routing
ARP - finds MAC addresses from known IPs
RARP - finds IPs from known MAC addresses
ICMP - provides diagnostics, used by ping and traceroute Network Access

CIDR BASICS

255.0.0.0 /8
255.128.0.0 /9
255.192.0.0 /10
255.224.0.0 /11
255.240.0.0 /12
255.248.0.0 /13
255.252.0.0 /14
255.254.0.0 /15
255.255.0.0 /16
255.255.128.0 /17
255.255.192.0 /18
255.255.224.0 /19
255.255.240.0 /20
255.255.248.0 /21
255.255.252.0 /22
255.255.254.0 /23
255.255.255.0 /24
255.255.255.128 /25
255.255.255.192 /26
255.255.255.224 /27
255.255.255.240 /28
255.255.255.248 /29
255.255.255.252 /30

Network Cabling Funda

Straight-through - Connect PC to hub or switch (router to switch or hub)

Crossover - Connect hub to hub/ switch to switch/PC to PC


Rolled - Console connection for PC to router


Half Duplex Ethernet shares a collision domain resulting in lower throughput than Full

Duplex Ethernet which requires a point-to-point link between two compatible nodes
Causes of LAN congestion - Broadcast storms, too many hosts with a broadcast
domain, multicasting, low bandwidth, bottlenecks

Collision domain - Switches/bridges breakup collision domains, hubs extend them


Broadcast domains - Routers and VLANs breakup broadcast domains

CCNA Syllabus New 2014




IP Data Networks
  • Understand the operation of data networks.
  • Know the purpose and functions of network devices such as routers, switches, bridges and hubs.
  • Be able to select components to meet a specific network requirement.
  • Understand how certain applications can impact network performance.
  • Know the protocols, purpose and operation of both the OSI and TCP/IP models.
  • Describe the data flow between two hosts on a network
  • Be able to choose the most appropriate cables, media, ports and connectors to connect network devices and hosts to a LAN.
LAN Switching
  • Understand the media access control method for Ethernet.
  • Describe the basic switching concepts and the operation of switches.
  • Configure and verify switch configuration including remote access management.
  • Verify a network and switch operation using basic utilities such as ping, telnet and SSH.
  • Describe VLANs and the need for routing between VLANs.
  • Understand network segmentation and traffic management.
  • Be able to configure and verify VLANs.
  • Configure and verify trunking on Cisco switches.
  • Understand advanced switching technologies:
    • RSTP
    • PVSTP
    • EtherChannel
  • Be able to configure and verify PVSTP operation.
  • Describe the process of root bridge election.
IP Addressing (IPv4 and IPv6)
  • Describe the need for public and private addresses for IPv4.
  • Understand IPv6 addresses.
  • Describe the appropriate IPv6 addressing scheme for a LAN/WAN environment.
  • Describe the appropriate IPv4 addressing scheme for a LAN/WAN environment, including VLSM and summarization.
  • Describe the technologies required to run IPv6 and IPv4 concurrently such as dual stack.
IP Routing
  • Understand the basic routing concepts.
  • Understand the boot process of a Cisco router.
  • Configure and verify a basic router configuration using the command line interface.
  • Configure and verify both serial and Ethernet interfaces.
  • Be able to verify the network connectivity and configuration of a router.
  • Configure a static or default route given specific requirements, then verify.
  • Manage Cisco IOS files and image(s).
  • Understand Cisco IOS licensing.
  • Understand and distinguish different methods of routing and routing protocols.
  • Configure and verify EIGRP in a single autonomous system.
  • Configure and verify OSPF (v2 and v3) in a single area.
  • Configure and verify interVLAN routing using router-on-a-stick.
  • Be able to configure SVI interfaces.
IP Services
  • Configure and verify DHCP on a Cisco router.
  • Understand the features and applications of each type of ACL.
  • Be able to configure and verify ACLs.
  • Understand the basic operation of NAT.
  • Configure and verify NAT based on a set of network requirements.
  • Be able to configure and verify NTP as a client.
  • Recognize high availability FHRP.
  • Understand, configure and verify Syslog and utilize Syslog output.
  • Understand SNMP v2 and v3.
Network Device Security
  • Be able to configure and verify device security features.
  • Understand, configure and verify switch port security features.
  • Configure and verify ACLs for filtering network traffic.
  • Limit telnet and SSH access to a router by configuring ACLs.
Troubleshooting
  • Troubleshoot and correct common issues concerning IP addressing and host configurations.
  • Be able to utilize netflow and monitor data.
  • Troubleshoot and fix spanning tree operation.
  • Troubleshoot and resolve routing issues, including OSPF, and EIGRP.
  • Troubleshoot and correct VLAN problems.
  • Identify and resolve interVLAN problems.
  • Troubleshoot and resolve switch trunking issues.
  • Troubleshoot and fix ACL problems.
  • Troubleshoot and correct layer 1 problems.
  • Troubleshoot and correct WAN issues.
  • Troubleshoot EtherChannel issues.
WAN Technologies
  • Understand and identify different WAN technologies including:
    • Metro Ethernet
    • Frame Relay
    • VSAT
    • Cellular 3G and 4G
    • MPLS
    • T1/E1
    • ISDN
    • DSL
    • Cable
    • VPN
  • Configure and verify a serial WAN connection.
  • Configure Frame Relay on Cisco routers including verification.
  • Be able to configure and verify a PPP connection between two Cisco routers.
  • Configure and troubleshoot PPPoE.